package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^:\n]+://)?([^:#/\n]*)`)
var str = `http://www.google.com/
https://www.google.com:2000/
http://100.1.25.3:8000/foo/bar?abc.php=xxxx+xxxx
www.google.com
10.0.2.2:5000
localhost/
localhost/foo
google.com
http://///x`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}