const regex = new RegExp('^(?:[^:\\n]+://)?([^:#/\\n]*)', 'gm')
const str = `http://www.google.com/
https://www.google.com:2000/
http://100.1.25.3:8000/foo/bar?abc.php=xxxx+xxxx
www.google.com
10.0.2.2:5000
localhost/
localhost/foo
google.com
http://///x`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}