using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?:<p|\G(?!\A))(?:(?!<\/p>).)*?\K[\n\r]+";
string substitution = @"";
string input = @"<p dir=""ltr"">Test<br>
A
aa</p>
abcd
<p dir=""ltr"">Bbb</p>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}