using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<FilesMatch ""test"">)((.|\n)*?)(?=<\/FilesMatch>)";
string input = @"<FilesMatch ""test"">
Order deny,allow
deny from all
allow from 111.111.111.111
</FilesMatch>
<FilesMatch ""nottest"">
Order deny,allow
deny from all
allow from 222.222.222.222
</FilesMatch>
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}