import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<FilesMatch \"test\">)((.|\\n)*?)(?=<\\/FilesMatch>)";
final String string = "<FilesMatch \"test\">\n"
+ "Order deny,allow\n"
+ "deny from all\n"
+ "allow from 111.111.111.111\n"
+ "</FilesMatch>\n\n"
+ "<FilesMatch \"nottest\">\n"
+ "Order deny,allow\n"
+ "deny from all\n"
+ "allow from 222.222.222.222\n"
+ "</FilesMatch>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}