const regex = /(?<=<FilesMatch "test">)((.|\n)*?)(?=<\/FilesMatch>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<FilesMatch "test">)((.|\\n)*?)(?=<\\\/FilesMatch>)', '')
const str = `<FilesMatch "test">
Order deny,allow
deny from all
allow from 111.111.111.111
</FilesMatch>
<FilesMatch "nottest">
Order deny,allow
deny from all
allow from 222.222.222.222
</FilesMatch>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}