$re = '/(?<=<FilesMatch "test">)((.|\n)*?)(?=<\/FilesMatch>)/';
$str = '<FilesMatch "test">
Order deny,allow
deny from all
allow from 111.111.111.111
</FilesMatch>
<FilesMatch "nottest">
Order deny,allow
deny from all
allow from 222.222.222.222
</FilesMatch>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);