import re
regex = re.compile(r"(?<=<FilesMatch \"test\">)((.|\n)*?)(?=<\/FilesMatch>)")
test_str = ("<FilesMatch \"test\">\n"
"Order deny,allow\n"
"deny from all\n"
"allow from 111.111.111.111\n"
"</FilesMatch>\n\n"
"<FilesMatch \"nottest\">\n"
"Order deny,allow\n"
"deny from all\n"
"allow from 222.222.222.222\n"
"</FilesMatch>\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")