#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<\?xml [^?]*\?><(?<root>\w+)>(.*?)<\/\1>\n?"
Local $sString = "<?xml version="1.0"?><ClientRequest><RequestId>dasdad asdasd asd asd asda sdasd as dasd1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>" & @CRLF & _
"<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>" & @CRLF & _
"<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>" & @CRLF & _
"<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>" & @CRLF & _
"<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>" & @CRLF & _
"<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test><?xml version="1.0"?><lol><RequestId>1</lo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")