using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\?xml [^?]*\?><(?<root>\w+)>(.*?)<\/\1>\n?";
string input = @"<?xml version=""1.0""?><ClientRequest><RequestId>dasdad asdasd asd asd asda sdasd as dasd1</RequestId></ClientRequest><?xml version=""1.0""?><test><RequestId>1</RequestId></test>
<?xml version=""1.0""?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version=""1.0""?><test><RequestId>1</RequestId></test>
<?xml version=""1.0""?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version=""1.0""?><test><RequestId>1</RequestId></test>
<?xml version=""1.0""?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version=""1.0""?><test><RequestId>1</RequestId></test>
<?xml version=""1.0""?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version=""1.0""?><test><RequestId>1</RequestId></test>
<?xml version=""1.0""?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version=""1.0""?><test><RequestId>1</RequestId></test><?xml version=""1.0""?><lol><RequestId>1</lo";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}