use strict;
my $str = '<?xml version="1.0"?><ClientRequest><RequestId>dasdad asdasd asd asd asda sdasd as dasd1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test><?xml version="1.0"?><lol><RequestId>1</lo';
my $regex = qr/<\?xml [^?]*\?><(?<root>\w+)>(.*?)<\/\1>\n?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}