re = /<\?xml [^?]*\?><(?<root>\w+)>(.*?)<\/\1>\n?/
str = '<?xml version="1.0"?><ClientRequest><RequestId>dasdad asdasd asd asd asda sdasd as dasd1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test><?xml version="1.0"?><lol><RequestId>1</lo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end