// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)url\(((?:\/[^\/()]+?)+?\.(gif|png|jpg|jpeg|svg|woff|eot|ttf))[^)]*\)").unwrap();
let string = "url(/var/www/synergicNetwork/app/webroot/img/mosaico.png) no-repeat center center fixed; color:#fff; background-size:cover; url(/var/www/synergicNetwork/app/webroot/img/mosaico.png) no-repeat center center fixed; color:#fff; background-size:cover;
url(/ghfdgh/glyphicons-halflings-regular.eot?#iefix) format('embedded-opentype'),url(/fonts/glyphicons-halflings-regular.woff)";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}