import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<<<<<<< HEAD(?:(?!=======)[\\s\\S])*=======(?:(?!>>>>>>> \\w+)[\\s\\S])*>>>>>>> \\w+";
final String string = "// Somes code\n"
+ "$done['rules'] = TRUE;\n\n"
+ "<<<<<<< HEAD\n"
+ "$conf['some_unit_id'] = '4-qw-gg-ds-sometext';\n"
+ "=======\n"
+ "// Some Snippets Site Info\n"
+ "$conf['site_info'] = array(\n"
+ " 'customer_service_phone' => '+1 323223232\n"
+ " 'logo_path' => 'https://www.google.com/img/icons/src/logo.svg',\n"
+ " 'currency' => 'CAD',\n"
+ " 'https://www.youtube.com/user/somewebsite/ogog',\n"
+ " 'https://www.instagram.com/somewebsite/',\n"
+ " ),\n"
+ ");\n"
+ ">>>>>>> ff6df3435231fdff78fwsd83e7dffa0732eft554\n\n"
+ "// Somes code\n"
+ "$done['rules'] = TRUE;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}