#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)network=\{\n\s*ssid="(?<ssid>.*)"\n\s*psk="(?<psk>.*)"\n\s*key_mgmt=(?<key_mgmt>.*)\n\s*sim_slot="(?<sim_slot>.*)"\n\s*imsi="(?<imsi>.*)"\n\s*priority=(?<priority>.*)\n}"
Local $sString = "ctrl_interface=/data/misc/wifi/sockets" & @CRLF & _
"driver_param=use_p2p_group_interface=1" & @CRLF & _
"update_config=1" & @CRLF & _
"device_name=P580_ROW" & @CRLF & _
"manufacturer=LENOVO" & @CRLF & _
"model_name=Lenovo " & @CRLF & _
"model_number=Lenov" & @CRLF & _
"serial_number=hjhjh7" & @CRLF & _
"device_type=10-0050F204-5" & @CRLF & _
"os_version=01020300" & @CRLF & _
"config_methods=physical_display virtual_push_button" & @CRLF & _
"p2p_no_group_iface=1" & @CRLF & _
"" & @CRLF & _
"network={" & @CRLF & _
" ssid="test1"" & @CRLF & _
" psk="154695"" & @CRLF & _
" key_mgmt=WPA-PSK" & @CRLF & _
" sim_slot="-1"" & @CRLF & _
" imsi="none"" & @CRLF & _
" priority=1" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"network={" & @CRLF & _
" ssid="SSID2"" & @CRLF & _
" psk="test123456"" & @CRLF & _
" key_mgmt=WPA-PSK" & @CRLF & _
" sim_slot="-1"" & @CRLF & _
" imsi="none"" & @CRLF & _
" priority=19" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")