import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "network=\\{\\n\\s*ssid=\"(?<ssid>.*)\"\\n\\s*psk=\"(?<psk>.*)\"\\n\\s*key_mgmt=(?<key_mgmt>.*)\\n\\s*sim_slot=\"(?<sim_slot>.*)\"\\n\\s*imsi=\"(?<imsi>.*)\"\\n\\s*priority=(?<priority>.*)\\n\\}";
final String string = "ctrl_interface=/data/misc/wifi/sockets\n"
+ "driver_param=use_p2p_group_interface=1\n"
+ "update_config=1\n"
+ "device_name=P580_ROW\n"
+ "manufacturer=LENOVO\n"
+ "model_name=Lenovo \n"
+ "model_number=Lenov\n"
+ "serial_number=hjhjh7\n"
+ "device_type=10-0050F204-5\n"
+ "os_version=01020300\n"
+ "config_methods=physical_display virtual_push_button\n"
+ "p2p_no_group_iface=1\n\n"
+ "network={\n"
+ " ssid=\"test1\"\n"
+ " psk=\"154695\"\n"
+ " key_mgmt=WPA-PSK\n"
+ " sim_slot=\"-1\"\n"
+ " imsi=\"none\"\n"
+ " priority=1\n"
+ "}\n\n"
+ "network={\n"
+ " ssid=\"SSID2\"\n"
+ " psk=\"test123456\"\n"
+ " key_mgmt=WPA-PSK\n"
+ " sim_slot=\"-1\"\n"
+ " imsi=\"none\"\n"
+ " priority=19\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}