# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"network=\{\n\s*ssid=\"(?<ssid>.*)\"\n\s*psk=\"(?<psk>.*)\"\n\s*key_mgmt=(?<key_mgmt>.*)\n\s*sim_slot=\"(?<sim_slot>.*)\"\n\s*imsi=\"(?<imsi>.*)\"\n\s*priority=(?<priority>.*)\n}"
test_str = ("ctrl_interface=/data/misc/wifi/sockets\n"
"driver_param=use_p2p_group_interface=1\n"
"update_config=1\n"
"device_name=P580_ROW\n"
"manufacturer=LENOVO\n"
"model_name=Lenovo \n"
"model_number=Lenov\n"
"serial_number=hjhjh7\n"
"device_type=10-0050F204-5\n"
"os_version=01020300\n"
"config_methods=physical_display virtual_push_button\n"
"p2p_no_group_iface=1\n\n"
"network={\n"
" ssid=\"test1\"\n"
" psk=\"154695\"\n"
" key_mgmt=WPA-PSK\n"
" sim_slot=\"-1\"\n"
" imsi=\"none\"\n"
" priority=1\n"
"}\n\n"
"network={\n"
" ssid=\"SSID2\"\n"
" psk=\"test123456\"\n"
" key_mgmt=WPA-PSK\n"
" sim_slot=\"-1\"\n"
" imsi=\"none\"\n"
" priority=19\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.