# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=([^\?\&\=]+=)([^\&\=]+))(\&\1)/~/g;t' <<< "?price=5-10&price=10-15&price=15-20&sport=cricket&sport=boxing&sport=swimming&food=choclate&food=biscuits"