#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(^|\n)?<form\b.*?<\/form>"
Local $sString = "<p>Hey I am a boy</p>" & @CRLF & _
"<form id='id1' class='class1'>Content</form>" & @CRLF & _
"<p>Hey I am a girl</p>" & @CRLF & _
"<form id='id1' class='class1'>content</form>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)