use strict;
my $str = '<p>Hey I am a boy</p>
<form id=\'id1\' class=\'class1\'>Content</form>
<p>Hey I am a girl</p>
<form id=\'id1\' class=\'class1\'>content</form>';
my $regex = qr~(^|\n)?<form\b.*?<\/form>~sp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";