using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(script)\s(\w*)\s(\w*)\((?:([a-z|A-Z]+)\s\w+)?\)";
string input = @"script void bar(type foo)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}