package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(script)\s(\w*)\s(\w*)\((?:([a-z|A-Z]+)\s\w+)?\)`)
var str = `script void bar(type foo)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}