re = /,(?=(((?!\)).)*\()|[^\(\)]*$)/
str = 'off_sls_total numeric(12, 2), off_sls_profit numeric(12, 2), off_sls_profit_percent numeric(12, 2), off_profit numeric(12, 2), off_profit_percent numeric(12, 2)'
subst = ',\\n\\t'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result