import Foundation
let pattern = #",(?=(((?!\)).)*\()|[^\(\)]*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"off_sls_total numeric(12, 2), off_sls_profit numeric(12, 2), off_sls_profit_percent numeric(12, 2), off_profit numeric(12, 2), off_profit_percent numeric(12, 2)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #",\n\t"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)