$re = '/^[23]?[0-9][0-9]?$/m';
$str = '199
200
299
399
400';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);