# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/({{m(?:\|[^\|]+)*\|\|)([^}]+)(?=}})/$1($2)/gm;t' <<< "{{m|gem-pro|*karzijan?||to turn}}"