use strict;
my $str = '{{m|gem-pro|*karzijan?||to turn}}';
my $regex = qr/({{m(?:\|[^\|]+)*\|\|)([^}]+)(?=}})/mp;
my $subst = '$1($2)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";