import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "PRICE:\\s+\\$([\\.\\d]+)";
final String string = " <span class='product'>Cheese</span>\n"
+ " <ul class='product-details' >\n"
+ " <li class='price' id='Cheese-price'> PRICE: $32.23 </li>\n"
+ " <li class='weight' id='Cheese-weight'> WEIGHT: 100 lbs </li> \n"
+ " </ul>\n"
+ " <span class='product'>Apple</span>\n"
+ " <ul class='product-details' >\n"
+ " <li class='price' id='Apple-price'> PRICE: $2.23 </li>\n"
+ " <li class='weight' id='Apple-weight'> WEIGHT: 1 lbs </li> \n"
+ " </ul>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}