$re = '/&nb\s*sp;/m';
$str = '
&nb sp;
&nb sp;
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;