const regex = /\w*(?<!ENABLED_)MYSTUFF\w*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w*(?<!ENABLED_)MYSTUFF\\w*', 'g')
const str = `MYSTUFF
m_MYSTUFF
MYSTUFFIsGreat
allOf_MYSTUFF
ENABLED_MYSTUFF
m_ENABLED_MYSTUFF
ENABLED_MYSTUFFIsGreat
allOf_ENABLED_MYSTUFF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}