re = /\w*(?<!ENABLED_)MYSTUFF\w*/
str = 'MYSTUFF
m_MYSTUFF
MYSTUFFIsGreat
allOf_MYSTUFF
ENABLED_MYSTUFF
m_ENABLED_MYSTUFF
ENABLED_MYSTUFFIsGreat
allOf_ENABLED_MYSTUFF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end