$re = '/[A-Z]*\/?([^@]*)/';
$str = 'SIP/channel@domain';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);