package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?:0[1-9])|(?:[12][0-9])|(?:3[01])|[1-9])`)
var str = `29-02-2016 00:00:46.676 [qtp1746080167-2900285] [ERROR] DefaultDao - Error executing query.
java.lang.Exception: Update count not satisfied.
at com.til.etwealth.etmoney.db.entity.query.sql.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}