re = /(?:\b(?<digit>\p{N}+)|(?<word>\p{L}+)\b)|(?<rest>[^\p{Z}]+)/m
str = 'There are usually 100 to 200 words ++ -- ** in a paragraph'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end