httpthe literal text http (case insensitive) s?optionally matches the literal s (11510 / 1638 / 7316) (case insensitive)
:the literal : (5810 / 728 / 3A16)
\/the literal / (4710 / 578 / 2F16)
\/the literal / (4710 / 578 / 2F16)
.*any character (except for line terminators), repeated any number of times
\.the literal . (4610 / 568 / 2E16)
Non-Capturing Group(?:png|jpg) pngthe literal text png (case insensitive) jpgthe literal text jpg (case insensitive)