re = /(https?:\/\/.*\.(?:png|jpg))/i
str = 'http://sub.domain.com/uploads/files/23-11-2011/234552-574-2321-232/asd.png'
# Print the match result
str.match(re) do |match|
puts match.to_s
end