// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(https?:\/\/.*\.(?:png|jpg))").unwrap();
let string = "http://sub.domain.com/uploads/files/23-11-2011/234552-574-2321-232/asd.png";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}