import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]+\\.?[a-z0-9]+$";
final String string = "f.oo\n"
+ "foo.\n"
+ "f.o.o\n"
+ "fooo\n"
+ "f....\n"
+ "foo.txtasdfasdfasdfasfdasfdasfd\n"
+ "foo\n"
+ "foooo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}