re = /^[a-z0-9]+\.?[a-z0-9]+$/m
str = 'f.oo
foo.
f.o.o
fooo
f....
foo.txtasdfasdfasdfasfdasfdasfd
foo
foooo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end