import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\bSECOND LEVEL\\b\\n(?:(?!\\n\\n)[\\s\\S])*\\bDining:\\s*(\\d+)";
final String string = " MAIN LEVEL\n"
+ " Entrance: 11\n"
+ " Dining: 33\n\n"
+ " SECOND LEVEL\n"
+ " Entrance: 4444\n"
+ " Living: 5555\n"
+ " Dining: 666\n\n"
+ " THIRD LEVEL\n"
+ " Dining: 999\n"
+ " Kitchen: 000\n"
+ " Family: 33332\n\n"
+ " SECOND LEVEL\n"
+ " Entrance: 4444\n"
+ " Living: 5555\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}