using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(?'pair'(?'d'-)(?'lcv'\w+)(?'s'\s)(?'dol'\$)(?'o'\()(?'ucv'\w+)(?'c'\)))(?'es'\n?)";
        string substitution = @"${pair}";
        string input = @"-solutionName $(SolutionName)
-solutionAbbreviation $(SolutionAbbreviation)
-projectName $(ProjectName)
-projectAbbreviation $(ProjectAbbreviation)
-environmentAbbreviation $(EnvironmentAbbreviation)
-appServicePlanAbbreviation $(AppServicePlanAbbreviation)
-logicAppAbbreviation $(LogicAppAbbreviation)
-serviceBusNamespaceAbbreviation $(ServiceBusNamespaceAbbreviation)
-serviceBusQueueAbbreviation $(ServiceBusQueueAbbreviation)
-scanAppServicePlanLocation $(ScanAppServicePlanLocation)
-scanAppServicePlanSKUName $(ScanAppServicePlanSKUName)
-scanAppServicePlanSKUTier $(ScanAppServicePlanSKUTier)
-scanAppServicePlanNumberOfWorkers $(ScanAppServicePlanNumberOfWorkers)
-hockeyAppAPIUri $(HockeyAppAPIUri)
-hockeyAppAPIAuthenticationTenant $(HockeyAppAPIAuthenticationTenant)
-hockeyAppAPIAuthenticationAudience $(HockeyAppAPIAuthenticationAudience)
-hockeyAppAPIAuthenticationClientId $(HockeyAppAPIAuthenticationClientId)
-hockeyAppAPIAuthenticationSecret $(HockeyAppAPIAuthenticationSecret)
-hockeyAppAPIPollingInterval $(HockeyAppAPIPollingInterval)
-scanQueueNamespaceKind $(ScanQueueNamespaceKind)
-scanQueueNamespaceSkuName $(ScanQueueNamespaceSkuName)
-scanQueueNamespaceSkuTier $(ScanQueueNamespaceSkuTier)
-scanQueueNamespaceLocation $(ScanQueueNamespaceLocation)
-scanQueueNamespaceAuthorizationRulesLocation $(ScanQueueNamespaceAuthorizationRulesLocation)
";
        
        Regex regex = new Regex(pattern);
        string result = regex.Replace(input, substitution);
    }
}