using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\(|,(?=(?:[^""]*""[^""]*"")*[^""]*$)|\).*$";
string substitution = @"\n";
string input = @".selector(@background, height, font ""font-family, font family"", @width : 10px, ""red"");";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}