package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)friendly_name"?\s*:\s*"?([^"]*)`)
var str = `..."friendly_name":"Average House Temperature"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}