$re = '/friendly_name"?\s*:\s*"?([^"]*)/m';
$str = '..."friendly_name":"Average House Temperature"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);