re = /friendly_name"?\s*:\s*"?([^"]*)/m
str = '..."friendly_name":"Average House Temperature"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end