$re = '/PHOTO.*Jggg==\n/m';
$str = 'truc a garder
PHOTO trucs a supprimer Jggg==
PHOTO trucs a garder
truc a garder Jggg==
PHOTO trucs a supprimer Jggg==
truc a garder';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;