use strict;
my $str = '新发布的三星盖乐世S9采用Exynos9810处理器,RAM为4GB,电池容量为3000mAh。
期望将S9,Exynos9810,GB,mAh提取出来
如何将一个句子中的英文词组或者英文+数字词组识别出来
新发布的三星盖乐世S9的特性如下:1.采用Exynos9810处理器;2.RAM为4GB;3.电池容量为3000mAh。
期望将S9,Exynos9810,GB,mAh提取出来,该用什么方法,希望得到各位的指点,谢谢。';
my $regex = qr/[a-zA-Z]+\d+|(?<=\d)[a-zA-Z]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}