import Foundation
let pattern = #"^.*?(?:([-+]?[0-9]*\.?[0-9]+(?:[eE][-+]?[0-9]+)?).*|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.&.
0.0119885482338&.&.
.&2.25880593895
.&.&.&.&.&.&.&.
.&0.295142083575&.
0.708323350364
.&.&0.193766679861
.&.&.&.&7.65239874523E-4&.&.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)