const regex = /(?:[NV]|GH)?([0-9-]+(?:[SF]|[A-Z])?)+(?:[A-Za-z]{1,3}[0-9]+|DV|D)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[NV]|GH)?([0-9-]+(?:[SF]|[A-Z])?)+(?:[A-Za-z]{1,3}[0-9]+|DV|D)?', 'g')
const str = `10y4
4035sf
v10
v10y4
gh303
1526yuj23
10dv
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}