#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<(\w+).*?class="wp-caption-text".*?>[\s\S]*?<\/\1>"
Local $sString = "<p class="wp-caption-text"><span>android m marshmallow</span></p>" & @CRLF & _
"" & @CRLF & _
"<html>" & @CRLF & _
" <body>" & @CRLF & _
" <img src="a6marshmallow.jpg"/>" & @CRLF & _
" <p class="wp-caption-text"><span>android m marshmallow</span></p>" & @CRLF & _
" <div class="wp-caption-text"><p>a more complex example :oooooo</p></div>" & @CRLF & _
" </body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")